Azure DevOps US region is depredated, Timetracker in US region might be unavailable
Incident Report for 7pace Timetracker
Resolved
Azure DevOps is fully healthy again
Posted Apr 25, 2024 - 07:35 UTC
Identified
We identified Azure DevOps performance degradation that may lead to unstable Timetracker availability. We are waiting for Azure DevOps team to handle this issue.
Posted Apr 24, 2024 - 12:23 UTC
This incident affected: Timetracker: Central US (Timetracker Application) and Azure DevOps.