The deployed fix has been confirmed as working. We are continuing to monitor.
Posted Apr 23, 2026 - 13:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2026 - 18:20 UTC
Update
We are continuing to investigate this issue.
Posted Apr 22, 2026 - 13:57 UTC
Update
We are continuing to investigate this issue.
Posted Apr 22, 2026 - 13:56 UTC
Update
We are continuing to investigate this issue.
Posted Apr 22, 2026 - 13:54 UTC
Update
We are continuing to investigate this issue. A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2026 - 13:52 UTC
Investigating
We are currently investigating the reason for this issue. A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2026 - 13:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 21, 2026 - 12:00 UTC
Investigating
We are currently investigating the reason for this issue.
Posted Apr 20, 2026 - 13:45 UTC
This incident affects: Timetracker: West Europe (Timetracker Application), Timetracker: Central US (Timetracker Application), Timetracker: South India (Timetracker Application), Timetracker: Australia East (Timetracker Application), and Azure DevOps.